Woocommerce v2

Par défaut, l’API  REST Woocommerce est en version legacy. L’API que j’utilise est la dernière (du moment, au 12/4/2017), à savoir la v2.

Si comme moi, vous utilisez à la fois les API REST WordPress et Woocommerce, il est préférable de passer à la v2.

API Version WC Version WP Version Documentation
v2 3.0.x or later 4.4 or later
v1 2.6.x or later 4.4 or later v1 docs

 

Mon initialisation de l’API est de la forme :

def initBDD():
	print "initBDD_2"
	wcapi = API(
	url="http://localhost:8888/bxxx.fr/",
	consumer_key="ck_axxx349c",
	consumer_secret="cs_xxxd3b1",
	timeout=30,
	wp_api=True, 
	version="wc/v2"
	)	
	return wcapi